The attribute preceding_version_id in the class VERSION in the
common.change_control package should be renamed to preceding_version_uid,
which would more correctly indicate its purpose (the value of the
attribute is not just a version tree id, but a full uid of a version) amd
be consistent with the VERSION.uid attribute, which is of the same type.
The attribute should also be optional, since it cannot be set in the first
An invariant has to be added to define when it has to be set.