Uploaded image for project: 'Specification'
  1. SPEC-55

Redefine DV_ORDERED.less_than as infix function '<'

    Details

    • Type: Change Request
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Release 0.9
    • Component/s: openehr.rm.data_types
    • Labels:
      None
    • Change Description:
      Hide
      Redefine DV_ORDERED.less_than as:
      infix '<' (other: like Current): Boolean
      Show
      Redefine DV_ORDERED.less_than as: infix '<' (other: like Current): Boolean
    • Approved By:
      PG

      Description

      The function "less_than" of the class DV_ORDERED should
      be defined as an infix function '<' since infix and prefix
      functions are already used elsewhere. If there are concrete formalisms
      which do not support infix operators, this function can be renamed
      to "less_than" in the relevant ITS.

        Attachments

          Activity

            People

            • Assignee:
              OLDthomasbeale OLDthomasbeale
              Reporter:
              OLDthomasbeale OLDthomasbeale
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: