Details

    • Type: Change Request
    • Status: Closed
    • Priority: Trivial
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: Release 0.9
    • Component/s: openehr.rm.ehr
    • Labels:
      None
    • Change Description:
      Hide
      Rename EVENT_CONTEXT.author to composer. Make
      EVENT_CONTEXT.health_care_facility optional.
      Show
      Rename EVENT_CONTEXT.author to composer. Make EVENT_CONTEXT.health_care_facility optional.
    • Approved By:
      PG

      Description

      The EVENT_CONTEXT class needs some adjustments to better
      correspond to the reality it models. Firstly, 'author' should be
      renamed to 'composer', to correspond with the emerging CEN
      ENV13606 standard.
        
      Secondly, the health_care_facility attribute should be optional,
      since a care event could occur at the patient's home, with no
      involvement at all by a care delivery enterprise (e.g. creation
      of some observations; self-administration of a drug).

        Attachments

          Activity

            People

            • Assignee:
              OLDthomasbeale OLDthomasbeale
              Reporter:
              OLDthomasbeale OLDthomasbeale
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: