Correct modelling errors in DIRECTORY class and rename

Description

Various errors exist in the current definition of the
DIRECTORY class. Firstly, the class should be renamed
to VERSIONED_DIRECTORY to be consistent with other classes
which inherit from VERSION_REPOSITORY.

Secondly, the root attribute should be removed, since
FOLDER already has the folders and items attributes, and
no further attribute joining a VERSIONED_DIRECTORY object
to FOLDER objects is needed.

Assignee

JeffJ

Reporter

JeffJ

Raised By

None

Priority

Trivial
Configure