We're updating the issue view to help you get more done. 

Rename VERSION_REPOSITORY to VERSIONED_OBJECT

Description

Currently in the model, the class VERSION_REPOSITORY defines an
object whose job it is to maintain a stack of versions of a single
logical object, such as a COMPOSITION, in the same way as an "s." file
versions a normal file in SCCS, and a ",v" file in RCS. However, this
name is problematic in openEHR for at least 3 reasons:

  • the word "repository" implies something large, like a database

  • the descendants of this class are all named VERSIONED_XXX (rather
    than VERSION_XXX)

  • the word "repository" conflicts with other uses of the same word
    in the specifications.

Status

Assignee

JeffJ

Reporter

JeffJ

Raised By

None

Priority

Trivial