We're updating the issue view to help you get more done.Learn more

Rename C_CODED_TEXT to C_CODE_PHRASE

There is an error in class naming in ADL and the openEHR archetype profile.
C_DV_CODED_TEXT should be named C_CODE_PHRASE. It has become clear now
because we put custom syntax into ADL before defining any C_XXX types.
But as can be seen if you review any of the archetypes, where the custom
syntax occurs e.g. from http://svn.openehr.org/knowledge/archetypes/dev/adl/openehr/ehr/entry/observation/openEHR-EHR-OBSERVATION.blood_pressure.v1.html

ELEMENT[at0008] occurrences ��� {0..1} ��� { -- Position
      value ��� {
          CODED_TEXT ��� {
                code ��� { -- ********
                    [local::
                     at1000, -- Standing
                     at1001, -- Sitting
                     at1002, -- Reclining
                     at1003; -- Lying
                     at1001] -- assumed value
                  } -- *****
             }
        }
    }

The AOM entity that the starred section above corresponds to is a CODE_PHRASE,
not a CODED_TEXT (which is one level up). To see this error clearly, this
archetype can be viewed in the ADL Workbench - see the path analysis with
"RM type" and "AOM type" columns turned on. "CODE_PHRASE" and "C_CODED_TEXT"
will be displayed for the node in the above example, which of course do not match.

This means that the openEHR archetype profile is in error, and the
C_DV_CODED_TEXT class has to be renamed. This won't actually affect
any archetypes, but it will affect the archetype tools, and the ADL
production rules, since the name c_coded_text appears in the .y
specification. The change will also not affect any semantics either,
so no-one has to make the change immediately.

Status

Assignee

JeffJ

Reporter

JeffJ

Change Description

Changes made: - rename C_CODED_TEXT to C_CODE_PHRASE - rename relevant production rules in cadl_validator.y file to include "c_code_phrase" not "c_coded_text".

Approved By

PG

Fix versions

Priority

Minor