The attribute name magnitude would be more technically correct than 'value', and the latter is confusing because it leads to references to the magnitude of a QUANTITY ELEMENT as 'value.value'. Correspondingly, the derived property canonical_value should be renamed to canonical_magnitude.
The attribute name magnitude would be more technically
correct than 'value', and the latter is confusing because
it leads to references to the magnitude of a QUANTITY ELEMENT
as 'value.value'. Correspondingly, the derived property
canonical_value should be renamed to canonical_magnitude.