We're updating the issue view to help you get more done. 

Four minor design decisions for REST Query API

Description

1. Undocumented "fetch" default;
Default for “offset” is 0 (good) but what should be the default for ”fetch”? I assume infinity/all, but thar should be mentioned to avoid implementerts silently trimming off results.

2. Timeout;
Could we assume that a query execution timeout limit, preferrably configurable in implementations, will kill stupidly big queries and send a http error code (400?). If so, then that should be mentioned so that implementers can be expected to handle the error.

3. Prefix for variables;
Should we use : or $ to prefix aql variables? I think AQL spec uses $ and that would be more familiar for developers.
Also ":" can get messed up in bad implementations of URL handling (I guess ":" is a Marand leftover)

4. Inconsistent naming;
Unify naming and style for: dynamic_parameter, dynamic-query-parameters and dynamic_query_parameter

Environment

None

Status

Reporter

Erik Sundvall

Labels

None

Components

Affects versions

ITS Release 0.9.0

Priority

Major